redondear a un número fijo de dígitos

La función ROUND de Excel permite modificar un número asignándole un número específico de decimales. Por ejemplo, si la celda A2 contiene el número 1234.5678, la fórmula =ARROUND (A2;2) da el resultado 1234.57 (note que el segundo decimal ha sido redondeado a su mayor valor, siendo el siguiente mayor o igual a 5). Todo esto es muy clásico. El número de decimales puede ser negativo, en este caso, el redondeo se realiza sobre potencias de diez. Así, con nuestro mismo ejemplo, =ARRONDI(A2;-1) devuelve el valor 1230 (o 1234.5678 redondeado a la decena más cercana). Con un argumento de -2, el redondeo sería al centenar (1200) más cercano y así sucesivamente.

Pero la función ARRONDI tiene un defecto: no permite pedir un redondeo a un número impuesto de «cifras significativas», un concepto ampliamente utilizado en la ciencia. Por ejemplo, manteniendo sólo dos dígitos significativos, 345000 se redondearía a 340000 y 0,234567 se convertiría en 0,23 con, como puede ver, un número variable de decimales. El objetivo es definir una precisión global y así es como funcionan la mayoría de los dispositivos de medición. Para obtener este resultado, basta con utilizar, como segundo argumento de la función ARRONDI, el logaritmo decimal del número a redondear, ya que éste depende del número de dígitos de su parte entera. Así, la fórmula =ARRONDI(A2;1-LOG(E2)) mantiene los dos primeros dígitos de A2. Para mantener tres dígitos significativos, reemplace 1-…… por 2-……

Leave a Reply

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *